엘라스틱서치 plugin 설치시 ERROR: unknown command [-install]. Use [-h] option to list available commands 와같은 에러가 발생합니다.


이는 1.X 버전때와 달리 플러그인 설치 커멘드의 변화가 조금 있어서 그렇다고 하네요.



제가 설치한 엘라스틱서치는 2.3.1 버전입니다.


아래 처럼 설치 명령 커멘드의 변화가 있습니다.



기존 명령어 

bin/plugin -install mobz/elasticsearch-head



변경된 명령어

bin/plugin install mobz/elasticsearch-head



차이점이 느껴지십니까?

install 옵션 앞에 -가 사라졌습니다.


ㅎㄷㄷ


이거때문에 한참을 검색해봤네요.



+ Recent posts